Home Discussion Colfax Cluster I can connect but something goes wierd

This topic contains 2 replies, has 2 voices, and was last updated by  marcus 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #8668

    marcus
    Participant

    the summary of the commands and their outputs have used:

    ls -l ~/Documents/Cursera/colfax-access-key-*
    -rw——-@ 1 molivag staff 1675 Mar 3 22:53 /Users/molivag/Documents/Cursera/colfax-access-key-24835.dms

    ls -l ~/.ssh/config
    -rw——- 1 molivag staff 189 Mar 9 22:14 /Users/molivag/.ssh/config

    cat ~/.ssh/config
    Host colfax
    User u24835
    IdentityFile ~/Documents/Cursera/colfax-access-key-24835.dms
    ProxyCommand ssh -T -i ~/Documents/Cursera/colfax-access-key-24835.dms guest@cluster.colfaxresearch.com

    ssh colfax
    /etc/profile.d/lang.sh: line 19: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8): No such file or directory
    Last login: Sat Mar 9 22:37:53 2019 from 10.5.0.7
    -bash: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8): No such file or directory

    Work but, due to the output of the last command (ssh colfax) I guess something does not work completely fine.

    Any help is valuable.

    Thanks

    #8676

    Andrey
    Keymaster

    It probably has to do with the locale settings on the computer from which you are logging in. You can probably ignore it, unless it interferes with compilation or terminal I/O. If you find any interference, you can try to set the environment variable LC_ALL=en_US before logging in to the cluster. For example, if you are logging in from a Bash shell, you would do:

    export LC_ALL=en_US
    ssh colfax
    #8684

    marcus
    Participant

    Thank you,

    You are right, the warning is due to local settings on my computer. I work on mac and I solved it by unchecked the option “Local environment variables set on startup”

    I saw the solution here:
    https://en.stealthsettings.com/fix-macos-terminal-error-warning-setlocale-lc_ctype-change-locale-utf-8-file-directory.html

    Again, thank you for your time.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.